Transfer rate estremamente bassa durante il processo di backup/imaging del disco: come mai?

Se Windows genera un errore, hai un problema di virus o vuoi discutere/segnalare l'uscita della nuova versione di un software per la piattaforma Microsoft, questa è la sezione giusta.
Regole del forum
Rispondi
Avatar utente
Matilda12
Livello: DVD-ROM (5/15)
Livello: DVD-ROM (5/15)
Messaggi: 103
Iscritto il: ven ott 18, 2013 2:18 pm
Località: Marche

Transfer rate estremamente bassa durante il processo di backup/imaging del disco: come mai?

Messaggio da Matilda12 » mer lug 10, 2019 7:45 pm

Salve a tutti! :)

La questione è la seguente.
Nel mio elaboratore fisso ho i dischi interni già indicati in QUESTO post.
In particolare:
  • un disco SSD Samsung da 500 GB (partizione MBR con file system NTFS), contenente il sistema operativo Win 10 PRO e tutti i vari programmi;
  • un disco fisso Seagate tradizionale da 2TB (partizione MBR con file system NTFS);
  • un disco fisso Western Digital tradizionale da 4TB (partizione GPT con file system NTFS), utilizzato per immagazzinare i vari backup, comprese le immagini del disco SSD.
Per realizzare l'immagine completa del disco SSD sfrutto sia Macrium Reflect Free sia EaseUS Todo Backup Free, avendo cura possibilmente di dotarmi delle ultime versioni (ora, rispettivamente la 7.2 Build 4325 e la 11.5.0.2 Build 20190422 - quest'ultima stamane appena aggiornata).

Vista la consistente capacità del disco WD da 4 TB deputato ad accogliere i backup e, soprattutto, le intere immagini del disco SSD, nel tempo ho accumulato parecchie immagini dell'SSD.
Parlo di 8 o 9 immagini realizzate con Macrium e magari 5 o 6 immagini prodotte mediante EaseUS.

Recentemente ho notato che, all'atto di realizzare un'immagine, la "transfer rate" dall'SSD al disco WD da 4 TB è particolarmente bassa (si attesta intorno ai 100-200 Mb/s) e l'intero processo può richiedere sino a 50 minuti, sia che utilizzi Macrium sia che impieghi EaseUS; mentre in condizioni normali con Macrium richiede dai 12 ai 15 minuti e con EaseUS dai 18 ai 20 minuti.
Preciso che le immagini ottenute, indifferentemente con Macrium oppure EaseUS, hanno una dimensione tra i 55 e i 70 GB (a seconda delle pulizie che posso aver fatto o meno sull'SSD).

Dal sito Macrium ho recuperato questi due thread: Purtroppo non si sono rivelati di grande aiuto.

In passato, in una occasione ad esempio, è stato sufficiente riavviare l'elaboratore per tornare ad avere la mia solita "transfer rate", senza che poi il problema si fosse ripresentato; sino a stamane almeno.

Ho eseguito un chkdsk (con opzione /R) di tutti i dischi, non riscontrando alcuna sorta di problemi o errori.

Quindi, avendo a disposizione due dischi fissi tradizionali, ho pensato di cambiare il disco di destinazione dell'immagine, optando per quello Seagate da 2 TB: la velocità di trasferimento era quella attesa, ossia tra 1.1 Gb/s e 1.4 Gb/s (rilevata con Macrium).
Non pago, con un programmino ad hoc, ho iniziato la copia di questa immagine sul disco WD da 4 TB e, anche attraverso questo programmino, mi venivano restituiti velocità di trasferimento basse e tempi di completamento dell'operazione intorno ai 40/50 minuti.

Ho fatto tutto questo per cercare di circoscrivere il problema ed escludere difetti, in senso lato, dell'SSD, piuttosto che di Macrium o EeaseUS.

Addirittura ho eliminato (e successivamente reinstallato) Windows Sandbox, visto che da qualche parte si sosteneva che la presenza di ambienti virtuali avrebbe potuto nuocere al processo di creazione dell'immagine del disco: nessun cambiamento/vantaggio apprezzabile. :cry:

Il fatto è che il disco fisso tradizionale WD da 4 TB è il più nuovo di tutti e le sue condizioni risultano essere in ordine, come emerso dai diversi test che sullo stesso ho eseguito.

Ho pensato allora: sarà un problema di "affollamento" e quindi di allocazione di file di grandi dimensioni sul disco WD da 4 TB?
Cioè: se all'apparenza il disco WD da 4 TB non presenta problemi, può essere che io lo abbia caricato con troppe immagini del disco SSD?

Quindi sono andato a guardare quante immagini avessi stipato nel disco WD e, oggi, ho trovato circa 10 immagini realizzate con Macrium e 8 prodotte con EaseUS. La capacità residua disponibile del disco è meno della metà (dunque oltre 2 TB già impegnati).
Ho eliminato le immagini più vecchie e lanciato sia Macrium sia EaseUS, ottenendo durante l'imaging completa del disco SSD:
  • con Macrium, una "transfer rate" oscillante da 1.4 Gb/s a 1.9 Gb/s, tranne la fase iniziale (a 700 Mb/s circa) e quella centrale (con un crollo a meno di 300 Mb/s); l'immagine poi è stata realizzata nel tempo previsto di circa 16 minuti;
  • con EaseUS, che non fornisce "transfer rate", l'immagine è stata prodotta nel tempo solito previsto di circa 18/20 minuti.
A questo punto la domanda che mi pongo e pongo è: il ritorno a una velocità di trasferimento consueta, tra 1.1 Gb/s e punte di 1.9 Gb/s, durante l'imaging del disco SSD, può essere dipeso dall'aver fatto pulizia nel disco fisso tradizionale dove immagazzino le immagini?

Grazie a chiunque avrà avuto la pazienza di leggere tutto 'sto papiro ... :imbarazzo:
... ho pensato di evidenziare in grassetto i passi salienti, così da rendere - spero! - la lettura più scorrevole ... adesso vado a flagellarmi per la farraginosità di questo post ... :frusta:frusta:frusta
... grazie ancora! :brindisi
"Facesti come quei che va di notte, che porta il lume dietro e sé non giova, ma dopo sé fa le persone dotte"
Dante (Purgatorio, Canto XXII)

Rispondi
  • Argomenti simili
    Risposte
    Visite
    Ultimo messaggio