Assenza di windows 7 dal menu scelta SO

Non importa se ti serve una mano per partire o se vuoi un consiglio avanzato: gli utenti "del Pinguino" hanno una risposta per ogni necessità.
Regole del forum
Rispondi
Avatar utente
sexirutto
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1085
Iscritto il: ven mag 03, 2013 12:18 pm
Località: Sardegna

Assenza di windows 7 dal menu scelta SO

Messaggio da sexirutto »

Ragazzi mi è sparito windows 7 dalla scelta dei sistemi operativi, con un update-grub non ho avuto la risposta che cercavo, è ancora assente, cosa dovrei fare per rispistinarlo?
Notebook: WINDOWS 10 64 Bit

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da System » mer gen 15, 2014 3:47 pm


Avatar utente
farbix89
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1097
Iscritto il: mer mag 01, 2013 4:39 pm
Località: Italia

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da farbix89 »

Per caso Windows 7 era ibernato prima di installare GRUB?

Puoi in ogni caso provare a reinstallare GRUB e vedere se risolvi

http://wiki.ubuntu-it.org/Amministrazio ... Ripristino

Avatar utente
sexirutto
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1085
Iscritto il: ven mag 03, 2013 12:18 pm
Località: Sardegna

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da sexirutto »

farbix89 ha scritto:Per caso Windows 7 era ibernato prima di installare GRUB?

Puoi in ogni caso provare a reinstallare GRUB e vedere se risolvi

http://wiki.ubuntu-it.org/Amministrazio ... Ripristino
Windoes 7 per quel che ricordo non era ibernato,mi ricordo che 3 giorni fa ho spento il pc da windows e non ho avuto problemi,il giorno dopo ho avviato lubuntu e li avevo la scelta del SO,poi esattamente il giorno successivo accendo il pc e mi da prima la voce del missing mbr,poi ho sistemato quella però non riesco più ad accedere alla scelta del SO, ieri ho provato subito questa guida, tempo fa l'avevo gia usata e mi era tornata utilissima, però mi torna sempre lo stesso errore quando vado a digitare

Codice: Seleziona tutto

 grub-install /dev/sda
lui mi dice

Codice: Seleziona tutto

 mkdir: impossibile creare la directory "/boot/grub/i386-PC": Permesso negato
Arrivo al passaggi tre della guida senza problemi,siccome su fdisk -l il mio sda1 è lubuntu salto al passaggio di install grub e da li ho alti problemi,ho provato a digitare anche

Codice: Seleziona tutto

grub-install --recheck /dev/sda
ma mi torna la stessa stringa dl permesso negato.
Notebook: WINDOWS 10 64 Bit

Avatar utente
hashcat
Livello: Storage Area Network (12/15)
Livello: Storage Area Network (12/15)
Messaggi: 1946
Iscritto il: gio mag 02, 2013 4:13 pm

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da hashcat »

Hai impartito i comandi con i privileggi d'amministratore? Riprova anteponendo sudo al comando (sudo [SPAZIO] comando).
“The quieter you become, the more you can hear”

Avatar utente
farbix89
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1097
Iscritto il: mer mag 01, 2013 4:39 pm
Località: Italia

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da farbix89 »

hashcat ha scritto:Hai impartito i comandi con i privileggi d'amministratore? Riprova anteponendo sudo al comando (sudo [SPAZIO] comando).
:yes

Nella guida infatti si ottiene via Live i permessi di su, senza i quali non riesci ad installare in chroot :->

Avatar utente
sexirutto
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1085
Iscritto il: ven mag 03, 2013 12:18 pm
Località: Sardegna

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da sexirutto »

Si l'ho gia fatto ma mi rida sempre lo stesso errore, per scrupolo lo rifaccio magari lo prende ora ;)
Notebook: WINDOWS 10 64 Bit

Avatar utente
sexirutto
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1085
Iscritto il: ven mag 03, 2013 12:18 pm
Località: Sardegna

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da sexirutto »

hashcat ha scritto:Hai impartito i comandi con i privileggi d'amministratore? Riprova anteponendo sudo al comando (sudo [SPAZIO] comando).
scusate per il cross posting, non mi fa editare l'altro messaggio comunque ho riprovato e sono arrivato al momento di digitare

Codice: Seleziona tutto

sudo chroot /mnt
questa volta l'ha preso,infatti l'utente è diventato utente root(giuro che stamattina ho scritto uguale ma non l'ha preso, adesso si, ora l'unica cosa che penso è ce ho sbagliato a digitare oopure boh lo saprà lui), fa nulla ,l'importatne è che l'abbia preso al momento dell'installazione del grub mi da questo messaggio:

Codice: Seleziona tutto

/usr/sbin/grub-bios-setup: avviso;ì: il settore 62 è già in uso dal programma "FlexNet", viene saltato. Questo software potrebbe causare problemi di avvio, o altri nel futuro. Informre gi autori e avvisarli di non archiviare dati nell'intervallo del MBR..  
Installazione completa, nessun errore segnalato.
poi ho comunque update grub e mi da solo linux e memtest senza far vedere nella lista windows.

Ora... come mai windows è sparito da solo??e flexnet lo posso installare da linux??in rete ho trovato solo che si installa da dos o da windows....
Notebook: WINDOWS 10 64 Bit

Avatar utente
sexirutto
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1085
Iscritto il: ven mag 03, 2013 12:18 pm
Località: Sardegna

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da sexirutto »

Ho fatto un giro in rete e mi sembra di aver capito che Grub2 sia andato "scontrarsi" colsttore occupato da FleXnet e che di conseguenza questi due siano entrati in contrasto e FleXnet mi abbia impallato l'avvio del sistema operativo, in questo caso windows 7,c'è chi dice di formattare a basso livello oppure come una piccola guida che ho trovato c'è una possibilità di "liberare il settore conteso" .
Ho capito bene oppure c'è qualcosa di diverso che mi sfugge???
Notebook: WINDOWS 10 64 Bit

Avatar utente
ninja
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 487
Iscritto il: lun ago 26, 2013 8:52 pm

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da ninja »

Leggevo in queste pagine del programma boot-repair... potrebbe semplificarti la soluzione del problema.

Avatar utente
sexirutto
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1085
Iscritto il: ven mag 03, 2013 12:18 pm
Località: Sardegna

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da sexirutto »

niente, neanche con questo toll ho risolto il problema, all'avvio appare solo lubuntu e memtest,la cosa buffa è che quando apro lubuntu e controllo dalla home(sulla sinistra dove ci sono i dispositivi) li c'è la partizione di seven, sto pensando seriamente di eliminare windows e lasciare lubuntu e basta, sul portatile ho windows 8, sul fisso lascio lubuntu e risolvo il problema, al limite potrei anche fare un'installazione da zero con la home separata magari cosi imparo qualcosa di nuovo, mo ci penso, credo che sto seven non ha voglia di riaffacciarsi :lol:

ho anche sentito parlare di manjaro linux molto bene e se non erro è tipo rolling release. se eventualmente elimino seven e reinstallo tutto da zero cosi da preparare per bene l'hdd potrei anche optare per un'altra distr, sinceramente nn capisco come il mbr si sia cancellato, poi se è per la storia del grub2 con questo flexnet è la prima volta che mi capita....
Notebook: WINDOWS 10 64 Bit

Avatar utente
sexirutto
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1085
Iscritto il: ven mag 03, 2013 12:18 pm
Località: Sardegna

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da sexirutto »

Ciao, penso di averle provate proprio tutte , ho provato anche questa guida http://www.chimerarevo.com/linux/linux- ... risolvere/
ma nulla, al riavvio windows non appare comunque, sto pensando seriamente di formattare l0intero disco e lasciare solo una distro linux (che sceglierò) e poi cia o ciao windows...

Non credo ci sia altro che si possa fare a questo punto.... :cry:
Notebook: WINDOWS 10 64 Bit

Avatar utente
Al3x
Amministratore
Amministratore
Messaggi: 3987
Iscritto il: mer mag 01, 2013 12:59 pm
Località: http://127.0.0.1

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da Al3x »

I :amore Sasha

Avatar utente
sexirutto
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1085
Iscritto il: ven mag 03, 2013 12:18 pm
Località: Sardegna

Re: Assenza di windows 7 dal menu scelta SO

Messaggio da sexirutto »

non me lo fa installare su penna, tempo fa lo volevo mettere su penna con lili ma non lo inseriva, oggi ho provato con universal usb installer e mi dice che manca il file di configurazione e non mi crea la penna live, però è più o meno come rescatux. tempo fa quando avevo il lettore vd lo utilizzai, o almeno ci provai perchè non riuscivo a fare nulla ,o per lo meno non mi faceva fare nulla, il problema è che adesso su penna non l'ho posso mettere.
Notebook: WINDOWS 10 64 Bit

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: Re: Assenza di windows 7 dal menu scelta SO

Messaggio da System » ven gen 17, 2014 9:05 pm


Rispondi
  • Argomenti simili
    Risposte
    Visite
    Ultimo messaggio