Iron browser su Ubuntu non si avvia più

Non importa se ti serve una mano per partire o se vuoi un consiglio avanzato: gli utenti "del Pinguino" hanno una risposta per ogni necessità.
Regole del forum
Rispondi
Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 416
Iscritto il: gio lug 25, 2013 5:39 pm

Iron browser su Ubuntu non si avvia più

Messaggio da Usag »

Salve,
uso Ubuntu 12.04 e fino a poche ore fa, adoperavo come browser principale Chrome; solo che quest'ultimo, non essendo il massimo per la privacy, mi aveva fatto convergere sulla decisione di installare il browser Iron e renderlo predefinito, disinstallando quindi Chrome, da Ubuntu.
A disinstallazione avvenuta di Chrome, riavvio (per conferma che tutto fosse andato per il meglio) Iron e parte regolarmente.
Poi spengo il computer e vado a mangiare; torno, lo riavvio e quando vado ad avviare Iron, sorpresa! semplicemente NON SI AVVIA!
eppure il browser è installato; a questo punto ho pensato: non è che Iron dipenda da Chrome, in qualche modo? nel senso che se non c'è Chrome, Iron non parte?
anche se mi sembra strano, in quanto - ripeto - appena disinstallato Chrome (ma non spento il pc), Iron è partito regolarmente.
Com'è possibile ciò?
ora sto scrivendo con Firefox, ma mi piacerebbe poter usare Iron, se possibile.
è capitata anche a qualcuno di voi una cosa simile?
grazie mille per le risposte.
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: Iron browser su Ubuntu non si avvia più

Messaggio da System » sab ago 03, 2013 9:17 pm


Avatar utente
Zane
Fondatore
Fondatore
Messaggi: 4667
Iscritto il: mer mag 01, 2013 11:20 am
Contatta:

Re: Iron browser su Ubuntu non si avvia più

Messaggio da Zane »

Prova a vedere se /var/log/syslog dice qualcusa quando lanci.

In alternativa, prova a cancellare il profilo. Non so bene quale sia per Iron, ma ti lascio i riferimenti per Chrome:

Google Chrome: ~/.config/google-chrome/Default
Chromium: ~/.config/chromium/Default

Al massimo, vai in ~/.config/ e poi fai ls -lFa e prova a guardare se salta fuori una cartella con il nome simile ad Iron oppure Chrome.
Zane - TurboLab.it

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 416
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Iron browser su Ubuntu non si avvia più

Messaggio da Usag »

Ciao,

In alternativa, prova a cancellare il profilo.
Allora, per Iron non ho trovato alcun profilo, seguendo il tuo percorso; tuttavia era ancora presente quello di Chrome, nonostante l'abbia già disinstallato da 3 giorni.
L'ho cancellato, come mi hai detto.

Prova a vedere se /var/log/syslog dice qualcosa quando lanci.
Attualmente posso lanciare solo Firefox, come browser, dal momento che Chrome (nonostante ci fosse ancora il profilo, ora cancellato) è disinstallato e Iron c'è ma non viene 'rilevato'.

Oltre a ciò, ho provato ad installare nuovamente Iron, scaricando il pacchetto .deb a 64 bit; ma quando vado ad installarlo, tramite l'Ubuntu Software Center mi propone come unica opzione, ' Reinstalla ', quindi vuol dire che c'è già.
Boh, non so che pensare...


Grazie mille cmq :)
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
ale2695
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 461
Iscritto il: mer mag 01, 2013 4:35 pm
Località: Novara
Contatta:

Re: Iron browser su Ubuntu non si avvia più

Messaggio da ale2695 »

Da Synaptic (se non c'è installalo col comando sudo apt-get install synaptic) cerca il pacchetto iron, e rimuovilo completamente tramite l'opzione apposita. Poi reinstallalo ;)
Viva TLI!!!

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 416
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Iron browser su Ubuntu non si avvia più

Messaggio da Usag »

Ciao,

Da Synaptic, cerca il pacchetto Iron, e rimuovilo completamente tramite l'opzione apposita. Poi reinstallalo ;)
Ok, proverò così.
Grazie :grazie :ciao
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 416
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Iron browser su Ubuntu non si avvia più

Messaggio da Usag »

Allora, ho installato Synaptic e cercato Iron, e infatti c'era. L'ho disinstallato completamente (compresi i file di configurazione) e reinstallato (dopo riavvio del pc, per sicurezza... :-D ), scaricando il pacchetto iron64.deb direttamente dal sito ufficiale; l'Ubuntu Software Center ha provveduto all'installazione, dopodiché ho avviato il browser, o meglio ho tentato di avviarlo, ma col solito risultato, vale a dire il vuoto pneumatico. allora, per sicurezza, ho aperto la finestra del monitor di sistema, per vedere i processi in esecuzione, e di Iron non c'era traccia neanche lì; praticamente, fra installazioni e disinstallazioni, ho buttato al vento 150 MB di dati. lo dico perché purtroppo per il momento son costretto a viaggiare con una chiavetta internet della Tim, da 2 GB al mese, quindi per me ogni MB scaricato 'pesa'.
e vabbè, pazienza...
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
eDog
Livello: Disco fisso (9/15)
Livello: Disco fisso (9/15)
Messaggi: 869
Iscritto il: gio mag 02, 2013 3:32 pm
Località: Vescovana (PD)

Re: Iron browser su Ubuntu non si avvia più

Messaggio da eDog »

Se apri un terminale, digiti

Codice: Seleziona tutto

iron
e premi invio, succede qualcosa? :penso
eDog
I am convinced that He (God) does not play dice. - Albert Einstein

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 416
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Iron browser su Ubuntu non si avvia più

Messaggio da Usag »

Iron e premi invio, succede qualcosa? :penso
MI dà:

Codice: Seleziona tutto

Comando "iron" non trovato. Forse si intendeva:
 Comando "cron" dal pacchetto "cron" (main)
 Comando "imon" dal pacchetto "isdnutils-base" (universe)
iron: comando non trovato


:muro
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
eDog
Livello: Disco fisso (9/15)
Livello: Disco fisso (9/15)
Messaggi: 869
Iscritto il: gio mag 02, 2013 3:32 pm
Località: Vescovana (PD)

Re: Iron browser su Ubuntu non si avvia più

Messaggio da eDog »

Che strano, se lo hai installato dovresti almeno vederlo globalmente :penso

Potresti provare a lanciare iron64 anziché iron :penso

Altrimenti, sempre da terminale:

Codice: Seleziona tutto

sudo dpkg-reconfigure iron
se non va prova con iron64 :penso
eDog
I am convinced that He (God) does not play dice. - Albert Einstein

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 416
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Iron browser su Ubuntu non si avvia più

Messaggio da Usag »

Ciao,
macché... niente da fare. continua col comando non trovato; non capisco.
ma, per ora sto andando con Firefox :grazie
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
ninja
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 487
Iscritto il: lun ago 26, 2013 8:52 pm

Re: Iron browser su Ubuntu non si avvia più

Messaggio da ninja »

Codice: Seleziona tutto

/usr/share/iron/iron
è questo il percorso completo dell'applicazione... non essendo presente nei percorsi predefiniti se non inserisci il percorso completo non viene trovata.

Da terminale eseguilo e vedi quali output restituisce, così almeno c'è una possibilità di capire perché non si avvia.

Per la prossima occasione vorrei ricordarti l'uso di un comando molto utile, whereis

Codice: Seleziona tutto

whereis iron
che come puoi notare restituisce i percorsi associati all'applicazione passata.

:)

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 416
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Iron browser su Ubuntu non si avvia più

Messaggio da Usag »

Ciao Ninja,
per qualche recondito e inspiegabile motivo, adesso mi rifiuta anche lo scaricamento, nel senso che mi chiede dove salvarlo e quando gli do la cartella, si chiude (uso Firefox), come se avessi dato Annulla; questa poi non mi era mai successa.
Comunque tranquillo, l'esser stato costretto a riutilizzare Firefox mi ha rifatto valutare in positivo questo browser, specie per una sua estensione in particolare (Anonymox) che gli altri browser non hanno, quindi per ora mi tengo questo; anche perché purtroppo fino a novembre mi tocca navigare con una pennina Tim a 2 GB al mese, quindi i download devo centellinarli per bene, non posso permettermi di 'buttarli via'; poi quando riavrò l'Adsl non ci sono più problemi.
Grazie lo stesso :grazie :sorrisone
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: Re: Iron browser su Ubuntu non si avvia più

Messaggio da System » gio ago 29, 2013 9:00 pm


Rispondi
  • Argomenti simili
    Risposte
    Visite
    Ultimo messaggio