Chromium e problemi con le estensioni

Non importa se ti serve una mano per partire o se vuoi un consiglio avanzato: gli utenti "del Pinguino" hanno una risposta per ogni necessità.
Regole del forum
Rispondi
Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 420
Iscritto il: gio lug 25, 2013 5:39 pm

Chromium e problemi con le estensioni

Messaggio da Usag »

Salve,
uso Ubuntu 12.04 (64 bit) e ho installato Chromium, volendo sostituirlo a Firefox; ho un paio di domande:
1. sono stato in passato un utilizzatore di Chrome, che ho disinstallato 6 mesi fa, a favore di Iron browser subito disinstallato in quanto non si avviava, 'fermandomi' su Firefox; con questo browser, un po' più pesante di Chrome, ho visto che ha un serio problema di velocità nello scaricamento di qualsiasi cosa; con Chrome, scaricavo file alla stessa velocità di Torrent (440 kb circa), mentre con Firefox, era già un miracolo se arrivavo a 28-30 kb. e questo si verificava sempre, non solo con qualche file. Allora ho deciso di installare Chromium e qui il primo fatto strano: una volta installato e avviato, me lo dà già tutto preconfigurato così com'era Chrome, quando ce l'avevo, col solito tema di sfondo, le estensioni e le impostazioni che avevo personalizzato. eppure con Chromium, si dovrebbe star un po' più tranquilli, in quanto a privacy.
2. Volevo installare l'estensione Ghostery in Chromium, ma quando vado a dare 'Aggiungi', mi dice 'Si è verificato un errore - Download interrupted', e questo lo fa con tutte le estensioni; di fatto posso tenermi quelle 3 che ho e non posso installare nient'altro. come mai? l'url di riferimento dal quale attinge alle estensioni è il solito di Chrome, ho già verificato, eppure niente.
3. Se questa storia delle estensioni non riuscissi a risolverla, dovrò tornare a Firefox, oppure virare su Opera, mai usato, ma ho sentito parlarne molto bene. Io sono molto attento alla sicurezza e alla privacy; Opera, in quanto a sicurezza e privacy, è allo stesso livello di Chromium, Firefox e simili?
Grazie mille a tutti per eventuali suggerimenti.
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: Chromium e problemi con le estensioni

Messaggio da System » ven set 27, 2013 3:20 pm


Avatar utente
ale2695
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 461
Iscritto il: mer mag 01, 2013 4:35 pm
Località: Novara
Contatta:

Re: Chromium e problemi con le estensioni

Messaggio da ale2695 »

Prova a dare da terminale il seguente comando:
rm -r ~/.config/chromium&&sudo apt-get install --reinstall chromium-browser
Apri poi Chromium e guarda se hai risolto. I preferiti te li dovrebbe aver importati accedendo con l'account Google in teoria :)
Viva TLI!!!

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 420
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Chromium e problemi con le estensioni

Messaggio da Usag »

Ciao,

Prova a dare da terminale il seguente comando:
rm -r ~/.config/chromium&&sudo apt-get install --reinstall chromium-browser
Apri poi Chromium e guarda se hai risolto. I preferiti te li dovrebbe aver importati accedendo con l'account Google in teoria
Mi sa che mi sono espresso male :). il problema non è Chromium che non si installa (è già funzionante); il problema è che Chromium non installa alcuna estensione.
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
ale2695
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 461
Iscritto il: mer mag 01, 2013 4:35 pm
Località: Novara
Contatta:

Re: Chromium e problemi con le estensioni

Messaggio da ale2695 »

Usag ha scritto:Ciao,

Prova a dare da terminale il seguente comando:
rm -r ~/.config/chromium&&sudo apt-get install --reinstall chromium-browser
Apri poi Chromium e guarda se hai risolto. I preferiti te li dovrebbe aver importati accedendo con l'account Google in teoria
Mi sa che mi sono espresso male :). il problema non è Chromium che non si installa (è già funzionante); il problema è che Chromium non installa alcuna estensione.
Appunto per quello: può essere qualche problema nella configurazione di Chromium. Per quello ti ho detto di rimuovere prima la cartella di configurazione del browser e poi reinstallarlo ;)
Viva TLI!!!

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 420
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Chromium e problemi con le estensioni

Messaggio da Usag »

Ah ok,
non avevo capito.
lo faccio subito, ti faccio sapere.
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 420
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Chromium e problemi con le estensioni

Messaggio da Usag »

Ok, ho dato il comando fatidico: il risultato è che le impostazioni di Chromium si sono azzerate (e questo è positivo), ovviamente le estensioni continua a non installarle; adesso ho perso anche altre 3 estensioni che avevo. Se su Chromium non c'è verso installare alcuna estensione, non è neanche pensabile che lo possa tenere come browser capriccioso. rimozione e torno a Firefox.
grazie lo stesso per il supporto :grazie ;)
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
sexirutto
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1090
Iscritto il: ven mag 03, 2013 12:18 pm
Località: Sardegna

Re: Chromium e problemi con le estensioni

Messaggio da sexirutto »

Con firefox per scaricare più velocemente utilizza l'estensione downthem all , io la uso da molto tempo e mi soddisfa, per il tuo problema, controlla se riesci almeno a scaricarla nel desktop,mi spiego, ci sono delle estensioni che a volte bisogna fare un drag&drop del file script direttamente nella pagina delle estension idi chrome/chromium, chorme c'è ed è stabile per linux, lo utilizzo su lubuntu senza problemi, provalo, la storia della privacy è anche suppongo veritiera, però cos'è orami non tracciato sul web?? a mio modesto parere dico questo, per i ldrag&drop segui questo link, qua lo spiegano meglio di me, http://www.trucchig.com/chrome/come-ins ... le-chrome/
Notebook: WINDOWS 10 64 Bit

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 420
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Chromium e problemi con le estensioni

Messaggio da Usag »

Ciao Sexirutto,

Con firefox per scaricare più velocemente utilizza l'estensione downthem all
Già fatto un po' di tempo fa; non solo non migliora, ma addirittura rallenta ulteriormente gli scaricamenti. già testato, fidati. l'ho tolto per disperazione.
Guarderò il link, grazie mille.
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
ninja
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 487
Iscritto il: lun ago 26, 2013 8:52 pm

Re: Chromium e problemi con le estensioni

Messaggio da ninja »

Ciao.

Se con l'installazione di Iron non si era creata l'icona di lancio nel menù, puoi crearne una tu...
... il comando per avviare Iron è:

Codice: Seleziona tutto

/usr/share/iron/iron
Essendo fuori dai percorsi predefiniti non viene avviato se non si provvede a passare il percorso completo.

[ciao]

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 420
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Chromium e problemi con le estensioni

Messaggio da Usag »

Ciao Ninja,
io ho la Dock identica al Mac; l'icona di Iron l'avevo trascinata lì dal Menù Applicazioni e si era inserita correttamente. l'avvio di Iron si era verificato regolarmente a installazione avvenuta. i problemi sono cominciati al successivo riavvio del sistema operativo: nonostante fosse sempre presente la voce nel Menù Applicazioni e l'icona nella Dock, Iron non si avviava più, ed era installato; infatti poi lo rimossi tramite Synaptic.
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 420
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Chromium e problemi con le estensioni

Messaggio da Usag »

Ok, aggiornamento: ho reinstallato per l'ennesima e ultima volta Iron; a sto giro, non esiste proprio da nessuna parte, né nel Menù applicazioni, né tanto meno nella Dock. inoltre ho dato il comando:

Codice: Seleziona tutto

/usr/share/iron/iron
e questo è il risultato:

Codice: Seleziona tutto

/usr/share/iron/iron: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory
Ovviamente Iron c'è eccome, controllato da Synaptic, ed è spuntato; l'Ubuntu Software Center mi propone infatti: Reinstalla.
beh a questo punto, anche questo giocattolo difettoso non posso che considerarlo come una parentesi chiusa definitivamente.
grazie lo stesso.
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 420
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Chromium e problemi con le estensioni

Messaggio da Usag »

Scusate, ultima cosa:
Visto che neanche con Chrome stesso riesce più a installare le estensioni (crx), sapete per caso il percorso in cui vengono scaricate, su Ubuntu? che vorrei provare a farlo a mano.
le guide su Internet lo danno per Windows, ma di Linux come al solito neanche a parlarne.
grazie mille.
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

Avatar utente
ninja
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 487
Iscritto il: lun ago 26, 2013 8:52 pm

Re: Chromium e problemi con le estensioni

Messaggio da ninja »

Si vede che non trova la libreria in questione...
... prova a vedere se è installata, se non lo è (il che mi sembrerebbe strano) allora installala con:

Codice: Seleziona tutto

sudo apt-get install libudev1


Oppure, semplicemente, manca il link alla libreria in /lib
ovvero manca /lib/libudev.so.1 e dovrai crearlo a mano facendolo puntare a /lib/libudev.so.1.x.y dove x e y sono le due sottoversioni della libreria...
... il comando per farlo sarà qualcosa tipo:

Codice: Seleziona tutto

sudo ln -s /lib/libudev.so.1.x.y /lib/libudev.so.1
dove al posto di x e y metterai i giusti valori (che dovrebbero saltare fuori premendo il tasto Tab per l'autocompletamento del comando).

Avatar utente
Usag
Livello: Chiavetta USB (8/15)
Livello: Chiavetta USB (8/15)
Messaggi: 420
Iscritto il: gio lug 25, 2013 5:39 pm

Re: Chromium e problemi con le estensioni

Messaggio da Usag »

Ciao Ninja,
ok proverò così non appena torno a casa mia, ora in ristrutturazione; quindi a fine mese. per adesso sono costretto ad usare Windows, per via della penna Internet (Olivetti 200, della Tim) che non ha i driver per Linux; quindi appena rientro in casa mia, riavrò nuovamente l'Adsl e lo farò.
Grazie :grazie ;)
Usag: Una bella donna non è colei di cui si lodano le belle gambe, ma quella il cui aspetto complessivo è di tale bellezza da togliere la possibilità di ammirare le singole parti

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: Re: Chromium e problemi con le estensioni

Messaggio da System » mar gen 07, 2014 2:03 pm


Rispondi
  • Argomenti simili
    Risposte
    Visite
    Ultimo messaggio