[Bug] Errore di certificato invalido causato dal CDN

Ti piacciono il sito e la community? Questo è il posto giusto per lasciare commenti, suggerimenti e... critiche.
Regole del forum
Rispondi
Avatar utente
hashcat
Livello: Storage Area Network (12/15)
Livello: Storage Area Network (12/15)
Messaggi: 1946
Iscritto il: gio mag 02, 2013 4:13 pm

[Bug] Errore di certificato invalido causato dal CDN

Messaggio da hashcat »

L'errore si manifesta nei browser sprovvisti del supporto all'SNI poiché il CDN utilizza un proprio certificato digitale valido (diverso da quello di TLI) ma è ospitato sullo stesso server (IP).

P.S.: Il problema è risolvibile in due modi:
  1. Utilizzando un apposito server per il CDN (come dovrebbe essere in progetto) con un unico certificato digitale
  2. Associando il CDN ad un sotto-dominio di TLI con un certificato digitale wildcard
;)
“The quieter you become, the more you can hear”

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: [Bug] Errore di certificato invalido causato dal CDN

Messaggio da System » dom ott 12, 2014 8:02 pm


Avatar utente
Zane
Fondatore
Fondatore
Messaggi: 4668
Iscritto il: mer mag 01, 2013 11:20 am
Contatta:

Re: [Bug] Errore di certificato invalido causato dal CDN

Messaggio da Zane »

Non mi risulta che ci siano browser moderni che non supportino SNI (Internet Explorer su Windows XP non è supportato né da Microsoft, né dal resto del portale), motivo per cui avevo giudicato il problema più che accettabile.

Ascolto comunque con interesse ogni ulteriore osservazione.
Zane - TurboLab.it

Avatar utente
hashcat
Livello: Storage Area Network (12/15)
Livello: Storage Area Network (12/15)
Messaggi: 1946
Iscritto il: gio mag 02, 2013 4:13 pm

Re: [Bug] Errore di certificato invalido causato dal CDN

Messaggio da hashcat »

Zane ha scritto:Non mi risulta che ci siano browser moderni che non supportino SNI (Internet Explorer su Windows XP non è supportato né da Microsoft, né dal resto del portale), motivo per cui avevo giudicato il problema più che accettabile.
Sono d'accordo: più che di un bug report si tratta semplicemente di una segnalazione.

P.S.: Un altro browser non recentissimo che non supporta l'SNI è quello di sistema in Android 2.3.X (e versioni precedenti).
“The quieter you become, the more you can hear”

Avatar utente
Zane
Fondatore
Fondatore
Messaggi: 4668
Iscritto il: mer mag 01, 2013 11:20 am
Contatta:

Re: [Bug] Errore di certificato invalido causato dal CDN

Messaggio da Zane »

hashcat ha scritto:più che di un bug report si tratta semplicemente di una segnalazione.
In questi termini, hai fatto benissimo a segnalarlo (non si sa mai :fiu )
Zane - TurboLab.it

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: Re: [Bug] Errore di certificato invalido causato dal CDN

Messaggio da System » lun ott 13, 2014 9:17 pm


Rispondi
  • Argomenti simili
    Risposte
    Visite
    Ultimo messaggio