[Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Ti piacciono il sito e la community? Questo è il posto giusto per lasciare commenti, suggerimenti e... critiche.
Regole del forum
Rispondi
Avatar utente
hashcat
Livello: Storage Area Network (12/15)
Livello: Storage Area Network (12/15)
Messaggi: 1946
Iscritto il: gio mag 02, 2013 4:13 pm

[Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da hashcat »

La descrizione del bug è inclusa nel titolo (URL); il problema si manifesta da qualche mese.
A causa di problemi d'accesso a "The Bug Genie" non posso aggiungere questa segnalazione al bug-tracker.

:fiu
“The quieter you become, the more you can hear”

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da System » sab ago 22, 2015 2:55 pm


Avatar utente
developerwinme
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1319
Iscritto il: mer mag 01, 2013 1:35 pm
Località: Como
Contatta:

Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da developerwinme »

Con Microsoft Edge, Chrome e Internet Explorer su Windows 10 vedo i grafici correttamente, mentre con Firefox no.
Con che browser hai problemi?
Marco Adriani
developerwinme.wordpress.com

Avatar utente
developerwinme
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1319
Iscritto il: mer mag 01, 2013 1:35 pm
Località: Como
Contatta:

Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da developerwinme »

Credo di aver trovato il problema: su Firefox viene dato un avviso relativo all'uso del nome "drawChart" nella riga 247 del JavaScript contenuto nel file HTML "statistiche".
Il problema sembra legato al fatto che la funzione drawChart è definita due righe più sotto e forse questo non è gradito all'interprete JavaScript di Firefox, che si trova un riferimento a qualcosa che ancora "non conosce".
Marco Adriani
developerwinme.wordpress.com

Avatar utente
developerwinme
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1319
Iscritto il: mer mag 01, 2013 1:35 pm
Località: Como
Contatta:

Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da developerwinme »

Ho provato ad aprire un bug, visto che ho accesso al bugtracker, ma continuo ad ottenere uno strano messaggio d'errore, sia con Edge che con Chrome.

Speriamo che Zane legga qui. :acch
Marco Adriani
developerwinme.wordpress.com

Avatar utente
hashcat
Livello: Storage Area Network (12/15)
Livello: Storage Area Network (12/15)
Messaggi: 1946
Iscritto il: gio mag 02, 2013 4:13 pm

Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da hashcat »

developerwinme ha scritto:Con Microsoft Edge, Chrome e Internet Explorer su Windows 10 vedo i grafici correttamente, mentre con Firefox no.
Con che browser hai problemi?
Credevo di aver sperimentato questo problema anche tramite Chrome ma, effettivamente, è da molto tempo che non lo uso (potrei sbagliarmi). Le osservazioni attuali sono relative alla versione 40 di Firefox.

:acch
“The quieter you become, the more you can hear”

Avatar utente
Zane
Fondatore
Fondatore
Messaggi: 4694
Iscritto il: mer mag 01, 2013 11:20 am
Contatta:

Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da Zane »

Vista segnalazione, grazie ragazzi. Confermo anch'io problema con Firefox 40.0.2, ok con Chrome ed Edge.

Per il bugtraq: ho aperto io, ma apprezzo moltissimo che ci abbiate almeno provato

Edit: fantastico, ora il bugtracker non funziona più nemmeno a me (undefined variable pipes)... mi appunto la segnalazione su carta :acch
Zane - TurboLab.it

Avatar utente
Zane
Fondatore
Fondatore
Messaggi: 4694
Iscritto il: mer mag 01, 2013 11:20 am
Contatta:

Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da Zane »

Ho riprovato con Firefox 46.0.1 ed ora direi che funziona correttamente (dopo aver accettato i cookie sul maledetto banner "cookie law").

Vi risulta?
Zane - TurboLab.it

Avatar utente
Andy94
Livello: Workstation (10/15)
Livello: Workstation (10/15)
Messaggi: 1364
Iscritto il: mer mag 01, 2013 1:35 pm
Località: Villorba (TV)

Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da Andy94 »

Sì, sembra andare senza problemi di sorta.
Se la pazienza è una virtù, attendere è un'arte...
Stiamo tornando...

Avatar utente
hashcat
Livello: Storage Area Network (12/15)
Livello: Storage Area Network (12/15)
Messaggi: 1946
Iscritto il: gio mag 02, 2013 4:13 pm

Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da hashcat »

Zane ha scritto:Ho riprovato con Firefox 46.0.1 ed ora direi che funziona correttamente (dopo aver accettato i cookie sul maledetto banner "cookie law").

Vi risulta?
Inizialmente ero perplesso in quanto sembrava non funzionare poi, dopo aver letto che nominavi il banner "cookie law", mi sono ricordato che ciò dipendeva dai filtri custom di uBlock Origin / Adblock Plus che avevo creato:

Codice: Seleziona tutto

! Impedisce caricamento userbar
||turbolab.it/js/userbar-loader.js

! Filtro estetico userbar
turbolab.it##div#userbar

! Filtro estetico phpBB Board Announcements
turbolab.it###phpbb_announcement

! Filtro estetico banner cookie law
turbolab.it##.cc_banner-wrapper
Confermo che, dopo aver disabilitato momentaneamente l'ultimo filtro ed accettato il banner cookie law, ricaricando la pagina i grafici vengono mostrati correttamente (Firefox 46.0.1).

:ciao
“The quieter you become, the more you can hear”

System
System
Bot ufficiale TurboLab.it
Bot
Messaggi:
Iscritto il: sab dic 31, 2016 6:19 pm
Contatta: Contatta

Re: Re: [Bug] Grafici assenti nella pagina "Statistiche d'accesso"

Messaggio da System » sab mag 28, 2016 3:31 pm


Rispondi
  • Argomenti simili
    Risposte
    Visite
    Ultimo messaggio